[Rivet] fastjet version for rivet

Andy Buckley andy.buckley at ed.ac.uk
Mon Oct 11 16:10:54 BST 2010

On 11/10/10 15:23, Hendrik Hoeth wrote:
> Hi Albert,
> Thus spake Albert Knutsson (albert.knutsson at desy.de):
>> Is there any major changes between 2.4.0 and 2.4.2 and a particular 
>> reason that I can not use 2.4.0 with Rivet? If not, maybe I can just 
>> hack the configure somehow and avoid this "block"?
> there are bug fixes in 2.4.2 which are important for Rivet, that's why
> we check for the version. Some analyses will crash Rivet if you try to
> use them with 2.4.0 or 2.4.1.

Particularly use of jet unfolding methods. I think that it's the
ClusterSequence::exclusive_ymerge_max method that crashes -- this is
IIRC not important for hadron collider studies, but is crucial for LEP,
JADE, SLD etc. which give constraints on jet rates.

If you really need it to work right now, and won't complain when the
LEP/JADE analyses fail, just hack the configure.ac file to remove/relax
the check. You will need to have an autotools suite installed for the
rebiuld to be successful if you make that change. And I recommend that
CMS make what is otherwise a "drop-in" bug-fix replacement of your
FastJet library... it must be *well* over a year since 2.4.0!


Dr Andy Buckley
SUPA Advanced Research Fellow
Particle Physics Experiment Group, University of Edinburgh

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

More information about the Rivet mailing list