[Rivet] CDF_1988_S1865951

Anton Karneyeu Anton.Karneyeu at cern.ch
Wed Nov 17 17:29:40 GMT 2010

Hi Hendrik,
thank you for investigation. Running AGILE with HepMC 2.06.03 fix this 
problem. But reveals another one with hepmc file generated by pythia8 
hepmc interface.

To reproduce, run attached scripts:
   $ ssh lxplus
   $ tar zxf bug1.tar.gz
   $ cd bug1/
   $ ./rivet-bug1.sh

Rivet will terminate with segmentation fault.

It seems, again, this is not 100% Rivet problem (as there are no 
problems running Rivet on Pythia6/AGILE hepmc files) and there is some 
issue with pythia8 hepmc interface.

Can you take a look? This will help me to debug pythia8 hepmc interface.


16.11.2010 21:03, Hendrik Hoeth:
> Hi Anton,
> Thus spake Anton Karneyeu (Anton.Karneyeu at cern.ch):
>> something wrong with analysis CDF_1988_S1865951. It gives negative Y
>> values for pT distribution histogram. Could you take a look?
> thanks for that bug report. It's kind of hard to blame Rivet in this
> case, though. The AGILe installation is using an ancient HepMC version
> (2.03.11) which doesn't have cross-section information support. If you
> then run a Rivet analysis that requires the cross-section for
> normalisation then anything can happen.
> True, Rivet should throw an error, and I'll fix that. But you should
> consider using a more recent version of HepMC like 2.06.
> Cheers,
>     Hendrik
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bug1.tar.gz
Type: application/x-gzip
Size: 3713 bytes
Desc: not available
URL: <http://www.hepforge.org/lists-archive/rivet/attachments/20101117/d9c8088c/attachment.bin>

More information about the Rivet mailing list