[Rivet] see only CCPythia when executing rivetgun

Andy Buckley andy.buckley at durham.ac.uk
Wed Jan 23 15:32:25 GMT 2008

Lars Sonnenschein wrote:
> Hello Andy
> I updated the head versions of agile and rivet.
> Agile does make now without any complaint.
> But when I try to run rivetgun the only available generator I can choose 
> from is CCPythia.

I'm copying this reply to the Rivet mailing list since this will
probably be a general problem for anyone using Rivetgun now. This, of
course, a feature rather than a bug - we need to move to using Genser's
generator libraries, so the generator loader has been changed to expect
Genser's library names (in the Genser .liblinks/<LCGTAG> directory on

I don't know if this works properly with the Genser libraries at the
moment - there are a couple of bugs in their build system which might
make it break. You can try by placing the path to the generator
libraries in the exported AGILE_GEN_PATH variable. There is also a
bin/mkGenserArea script in the AGILe build directory which can be used
(carefully!) to bootstrap your own local Genser area (FHerwig/FPythia
only at the moment) from the tarballs on the Genser web page.

All this will be documented in the manual/howto when I get a moment to
write it :)

> (I tried also the rivet configure option --enbable-rivetgun, but it does 
> not make any difference)

That is set true by default --- it only exists so that users can turn
OFF building rivetgun if they so wish (with the --disable-rivetgun switch).


More information about the Rivet mailing list